Jump to content
Akeno017

Stunt Rally Runtime Error/abnormal termination Win10

Recommended Posts

Akeno017

MSR.exe shortcut with /fromlauncher, fresh install, tried compatibility settings etc no luck

Game opens up into black screen with lego media audio playing with error message stated.
This appears to be the limit of what I can fix by just googling so came here hoping someone might have the solution.

Share this post


Link to post
Share on other sites
Cyrem

Hey Akeno,

 

Which version of the game do you have? Here's more information.

 

There is a /NOINTROVIDEO parameter which disables the videos. Add this after /FROMLAUNCHER. If it crashes due to the opening video, this may resolve it. But it only works on some versions of the game.

Share this post


Link to post
Share on other sites
Akeno017

So apparently nointrovideo fixed it, im very confused how but I greatly appreciate the help.

Edit: Nvm, it crashes on each videos after race boss intro etc

Share this post


Link to post
Share on other sites
Cyrem
13 hours ago, Akeno017 said:

So apparently nointrovideo fixed it, im very confused how but I greatly appreciate the help.

Edit: Nvm, it crashes on each videos after race boss intro etc

 

It sounds like you're missing the video codec for Indeo 5 (IV50) to play the videos. Try installing the Basic K-Lite codec pack which includes this codec.

Share this post


Link to post
Share on other sites
Akeno017

Community Codec wasn't sufficient I guess.
Greatly appreciate the help.

Share this post


Link to post
Share on other sites
DrSnuggly

It's been over a year now, but I've made some progress on this for my own setup, for whatever that's worth. I'm on Wine, but I think this should work for normal Windows installations, too. For me, Cyrem was on the right track about the Indeo 5 codec not being installed — it's just that the "Basic K-Lite codec pack" they recommended didn't work for me either. Instead, I figured out the instructions below.

 

For anyone trawling through old posts to try to fix this issue, here's the crash error message I was encountering every time a video would try to play (whether on game startup, winning/losing a race, or when viewing a boss intro video): 

Runtime Error!

Program: [path]/LEGO Stunt Rally/_msr.exe

abnormal program termination

 

For Windows Vista and above, this codec are actually already built into the OS, it's just that the DLL containing the codec isn't registered by default. To register the DLL containing the codec, type or copy/paste each of the lines below (minus the "C:/> " portion) into an elevated (Administrator) command prompt. PowerShell works, too.

(only enter the first line if on a 64-bit system, otherwise skip to the second command)
C:/> cd C:\Windows\SysWOW64
C:/> regsvr32 ir50_32.dll

If you need to unregister the DLL containing codec for any reason, you can enter the following commands:

(only enter the first line if on a 64-bit system, otherwise skip to the second command)
C:/> cd C:\Windows\SysWOW64
C:/> regsvr32 /u ir50_32.dll

 

For Windows XP and below (useful for when using a VM or Wine), you'll need to install the codec from free-codecs.com and use the "typical" install option. I know the website name sounds sketchy as hell, but apparently it's a semi-official repository for this codec? Regardless, it's the only one that really worked for me, and it didn't install any crapware — just the intended codec. I tried other installers from other sites, but they kept getting stuck on the "searching for Netscape installations" (lol). So take that as you will.

 

I also ended up using the alternate installer that someone created to work on more modern systems (works on XP and above), but I don't think that had much to do with my success here. This also automatically adds shortcuts that don't require the CD, if that interests you at all. If you do opt to use this installer, know that there's a minor bug that can make it fail to copy "dsetup.dll" from the install media to the application folder on the hard drive.

 

After doing the above, I was able to launch the game without needing to use /NOINTROVIDEO — since the game no longer crashes when trying to play a video.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.