Jump to content
ZuTheSkunk

LRR - Strange issue with lighting?

Recommended Posts

ZuTheSkunk

So I moved to a different laptop recently, and I found that for whatever reason, this laptop has some issues with displaying LRR's graphics correctly despite running on the same system as the previous one (Win7 64bit).

 

The primary issue is that for some reason the floor and some other elements are rendered 100% bright, with no regard for the surrounding lighting:

 

01882bb7c5.jpg

 

It's the same way whether I run the game with dxVooDoo or not. The only thing dxVooDoo managed to fix was the issue with the game not being able to display transparency.

 

The laptop has GeForce GTX 960M, i7-6700HQ and 16GB RAM.

Share this post


Link to post
Share on other sites
Cirevam

It kinda looks like what happens when you enable -ftm as a command-line parameter. The walls are shadowed but everything else ignores the global light source. If your install doesn't have any command-like parameters, use CLGen (it should be in the same folder as the EXE) to set the parameters to anything else. I think it writes to a registry location, so it might persist until you deliberately change it.

 

https://kb.rockraidersunited.com/Command-line_parameters#LEGO_Rock_Raiders

Share this post


Link to post
Share on other sites
ZuTheSkunk

I already tried using CLGen a few times, but it doesn't seem to be doing anything. Out of curiosity I tried searching for "Raiders" in the registry, but I don't think I found anything in there related to the selected card, so that might be a problem. The only other thing of note is that under HKEY_LOCAL_MACHINE/SOFTWARE/Wow6432Node/Lego Media/Games/RockRaiders/StandardParameters, the value automatically sets itself to "-ftm"; I tried manually changing that to "-best", but it didn't seem to do anything, and I think changing CLGen reverts that value.

 

EDIT: I just tried, out of sheer curiosity, to add the "-nm" command to my shortcut in addition to "-best", and that seems to have fixed it? Will need to test it further though.

EDIT2: Yes, everything seems to be looking normal now... the only exception would be how the green "swirl" on the teleportation effect for some reason does not have partial transparency, always staying fully visible.

Share this post


Link to post
Share on other sites
aidenpons
10 hours ago, ZuTheSkunk said:

I already tried using CLGen a few times, but it doesn't seem to be doing anything. Out of curiosity I tried searching for "Raiders" in the registry, but I don't think I found anything in there related to the selected card, so that might be a problem. The only other thing of note is that under HKEY_LOCAL_MACHINE/SOFTWARE/Wow6432Node/Lego Media/Games/RockRaiders/StandardParameters, the value automatically sets itself to "-ftm"; I tried manually changing that to "-best", but it didn't seem to do anything, and I think changing CLGen reverts that value.

 

EDIT: I just tried, out of sheer curiosity, to add the "-nm" command to my shortcut in addition to "-best", and that seems to have fixed it? Will need to test it further though.

EDIT2: Yes, everything seems to be looking normal now... the only exception would be how the green "swirl" on the teleportation effect for some reason does not have partial transparency, always staying fully visible.

Huzzah! It works! This is not always a given with LRR :P

 

Try taking -best out of your shortcut and just running a shortcut with no parameters to LegoRR.exe? Might do something.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.