Jump to content
ShinyPorygon1234

Lego Island 2 Install Failure

Recommended Posts

ShinyPorygon1234

Hello, recently I have had a kick to play the old Lego Games. I went through and started installing them all and Lego Island 2 is the only one that fails. The problem is the failure is caused by my disk being scratched since I have had the disc for over 14 years now. Now the problem is a single file. | data2.cab | I have read the global forum rules and I did see the part about not being able to share links to the full games ect. However I have added proof that I do own this game and I am wondering if there is any way I can get just that single file. 

 

Note: I couldn't figure out the image thing so I put them in an imgur gallery. The 3 images hold proof to the fact that I actually own it and showing the file failure. 

https://imgur.com/a/Gc8gf4w

Share this post


Link to post
Share on other sites
jamesster

Well, the game had two normal releases* but practically speaking there isn't much difference between them and the game probably wouldn't implode if you mixed and matched their contents.

 

Version A:

 

lhXCPpk.png

 

Version B:

 

3ORsfo7.png

 

I dunno which version you have but hopefully you can figure it out by comparing with the above screenshots (exact hours/potentially dates in the timestamps may appear shifted due to time zone shenanigans, but should still be distinguishable via minutes). Here's data2.cab from both versions: https://www.dropbox.com/s/eewbsevrdyww7m1/LI2 data2 cabs.zip?dl=1

 

* Plus a third, never properly released and seemingly unfinished "1.1" version that introduces as many new problems as much as it fixes old ones, but that's another story. It's not really useful as anything other than a curiosity.

Share this post


Link to post
Share on other sites
ShinyPorygon1234

Awesome, turns out I had version b. Thank you so much. 

Share this post


Link to post
Share on other sites
dcbstudios

Having some issues after install.

 

I just got a hold of the install ISO for LI2, however after mounting, running the install, and installing DirectX8 from the initial install pop-up... When I try to run the game via the "Play" option, the screen goes black... Waits a second... And gives me a "Lego Island 2.exe has encountered a problem and needs to close.....". I've tried a second time using a ZIP that contained "eup-li2" bin and cue file, respectively. I modified the CUE file to have the proper BIN name, ran the install, followed up with the DirectX8 install... Pushed play... And same result. 

 

Am I missing something similar to when you install Lego Rock Raiders and have to put the D3drm.dll in the folder... Or is just having the one ISO/BIN&CUE mounted not enough for this?

 

I'm running this on a Windows XP SP3 virtualbox and have gotten Lego Rock Raiders, Loco, and original Lego Island to work with no issues. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.