Jump to content
IncredulousPasserby

Forced Map Move Glitch

Recommended Posts

IncredulousPasserby

Hullo! Thanks for putting this site together - it's been my dream for years to finally beat this game and now I can. Well, maybe.

 

So, I've got Rock Raiders running. Everything works beautifully until the game forces the map to move. For instance, in the very first tutorial, when the game focuses on one of the running rock raiders, where the map is (the cavern, the raiders, etc) goes black and nothing I do will change that. The sound keeps playing and the UI remains interactive, so I can continue the tutorial until it requires me to select a rock raider. The same thing happens in the very first mission, when the rock raiders break through to the mini base and the game would focus you on the buildings. Even there, with full controls, I'm unable to get the map to move. The yellow button doesn't refocus me, and when I look at the radar in the upper left, it doesn't show the white box representing the camera at all. I also can't move the camera using the radar or the arrow keys. 

 

Specs: Windows 10. I've tried compatibility mode for Win XP SP2 and Win 98 - oddly, Win 98 is glitched to unresponsiveness, so I'm either using Win XP or native. I'm running the game as an administrator, I've tried with and without 16 bit colors, and with and without 640x480 resolution  I'm using dgVoodoo, and I've got the settings as recommended by Cyrem. I'm using an original 1999 disk, that I only got to work by using the method found on pcgamingwiki.com/wiki/Lego_Rock_Raiders. Just using dgVoodoo did not do the trick. It's very possible that a file is corrupted somewhere, either because of this or on my disk, but I was hoping someone has seen something along these lines and can provide me with a fix short of finding an ISO and putzing around with that. Thanks!

Share this post


Link to post
Share on other sites
Cyrem

Hey welcome, glad you got it running.


I've experienced this before, if I recall correctly, enabling V-Sync resolved it for me. It's a setting in the dgvoodoo configuration app under 'DirectX'. Give that a go and tell me how it affects the game.

 

P.S Most of that info on PCGW for LRR fixes came from here.

Share this post


Link to post
Share on other sites
IncredulousPasserby

It appears to be better. I'm able to make it through the first mission without issue, and the second mission also had no problems. The tutorial still did, annoyingly enough, so it may not be wholly fixed, but the game seems playable. Thanks!

Share this post


Link to post
Share on other sites
Cyrem
2 hours ago, IncredulousPasserby said:

It appears to be better. I'm able to make it through the first mission without issue, and the second mission also had no problems. The tutorial still did, annoyingly enough, so it may not be wholly fixed, but the game seems playable. Thanks!

You  could also try the " -fpslock" LRR parameter, it's meant to do the same thing... however LRR will do it instead of dgVoodoo, which may make a difference. Just create a shortcut to the LegoRR.exe and in the shortcut's poperties add "-fpslock" to the end of the target field. There are others you might like to play with as well.

Share this post


Link to post
Share on other sites
aidenpons

Try windowed mode as well? Should be just a click on the Mode Selection Screen from LRR itself, not in dgVoodoo's settings.

Share this post


Link to post
Share on other sites
Cyrem
1 hour ago, aidenpons said:

Try windowed mode as well? Should be just a click on the Mode Selection Screen from LRR itself, not in dgVoodoo's settings.

This occurs in both modes, It's like the camera goes out of range as everything still works, even the radar panel shows you RR's running around.

Share this post


Link to post
Share on other sites
IncredulousPasserby

Cyrem’s thought on what it might be makes sense, given what I saw. Also, windowed mode wasn’t really an option, due to the settings I used to make it run.

 

Of course, now the game’s crashing on Frozen Frenzy, and the fix in the other thread about that crash isn’t working, so.....that’s another day, I guess. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.