Jump to content
Yellowberry

LSR LSR not working on Windows 10 *sometimes*

Recommended Posts

Yellowberry

Hey folks, old user here that hasn't posted in ages. I've been trying to get LSR working on Windows 10 for about 2 weeks now, I've tried everything from compatibility mode, to dgVoodoo, to dxwnd (which is a fantastic piece of software that people don't seem to mention here), to d3d8to9 and other random things like fiddling with the registry. The thing is, I know it will work, because I somehow got it working earlier today, and I was able to start it and run it and even record a video. But it ran like garbage thanks to dgVoodoo and I wanted to see what I could do to make it run better, so I started to tweak things and then it just completely broke again.

 

Symptoms are as such:

Start the game with shortcut to:

_msr.exe /FROMLAUNCHER /NOINTROVIDEO

Game starts as usual, menu works fine, although horribly slow on dgVoodoo, go into racing menu, click quick race, and I hear the first light noise, and then the game immediately crashes.

 

No idea what causes it, I was reading something about the game possibly freaking out over a specific printer driver (HP DeskJet 500) due to poor programming.

 

Who knows, I'm stuck, and I need the wise communities help.

Share this post


Link to post
Share on other sites
Yellowberry

Alrighty, new developments. I feel like I have a corrupted version of the game. I have tried to run it in countless ways on several different machines, virtual and not, and still nothing. I'm going to attempt to source another copy from one of my friends who still has their original game disc.

 

So far:
Win10 (x64, i7, 16GB ram) - Starts and runs the menu fine, crashes when starting a race, demo race is not effected (debugger says there is loads of access violation errors [0xc0000005] and then it crashes)

Win7 (x64, Pentium 4, 4GB ram) - "LEGO Stunt Rally has stopped working" "The application was unable to start correctly (0xc0000005). Click OK to close the application."

Win98 (VM, 256MB ram) - "This program has performed an illegal operation and will be shut down."
WinXP (x32, VM, 4GB) - "_msr.exe has encountered a problem and needs to close."

 

Playing with the printer spooler doesn't do anything, and even installing a dummy printer doesn't work.

 

Pretty lost as to why I can't play this game.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.