Jump to content
Mr. Skeltal

LR1 Game Crashes When Going To Adjust Controls

Recommended Posts

Mr. Skeltal

So I have Racers running perfectly fine on my machine, along dgVoodoo on it, so I can run the game in higher resolutions, and apply anti-aliasing.

However, i'm not exactly a fan of the default controls, as I usually have Powerup's mapped to the Space Bar, Power Sliding on Left Shift, and Braking on Left Control (that way I can do super power slides quite easily)

Issue is, whenever I go to the control menu, the game will instantly crash back to the Desktop.

I thought it was an issue with my controller being plugged in, but unplugging it didn't change anything.

I doubt it's an issue with my machine, as I have had the game running fine on Windows 10 before, and with dgVoodoo.

I'm pretty sure I have the game running as Admin, with Windows 98 Compatibility enabled (I'll have to check, likely wont be able to report back till sometime later) 

The version of the game I run is the 1999 version with No-Disc protection (last I checked, I was one of two people on here that have a similar version)

The specs of my machine are:
Intel i5
Nvidia GTX 970
16GB RAM
Windows 7
750GB HDD

If any further info is needed, let me know, and I shall try and get back to you as soon as I can.

Share this post


Link to post
Share on other sites
jamesster

First time I've ever heard of that happening. I wonder if it's something with the 1999 version and/or compatibility mode? Could give the 2001 version a shot if you have any way of getting it. Otherwise, maybe the game simply doesn't like a driver you have installed, or something along those lines.

Share this post


Link to post
Share on other sites
Mr. Skeltal

Quick Update:

Seems it was Windows 98 Compatibility that broke it, as when I changed it to Windows XP SP3, the game works perfectly fine now. Why Windows 98 mode would not work, but XP SP3 mode does is beyond me.

EDIT: Apparently, the crashing issue when changing controls isn't just something I was having. This place: https://pcgamingwiki.com/wiki/Lego_Racers seems to document that happening to others as well

Edited by Mr. Skeltal
Provided extra info

Share this post


Link to post
Share on other sites
mumboking

I've never used any compatibility mode, only the -novideo argument in the shortcut.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.