Jump to content
Das Glückskekschen

[SOLUTION] Lego Rock Raiders on Windows 10

Recommended Posts

WhiteByte101

Hey, I followed the steps.

 

I start LegoRR.exe, it goes into 640 x 480, and shows the prompt where I choose "windowed". I press OK and then it goes back to 1080p with nothing happening :/

Share this post


Link to post
Share on other sites
Das Glückskekschen
On 11/2/2019 at 5:29 PM, OldWizard said:

Hi there, I've done all the steps but when I run LegoRR.exe my screen goes black for a second, then nothing happens.

When I try running your "rr-fix" it says "error: please start Lego Rock Raiders first !!!"

 

Any thoughts?

Yes, your game is not even starting.

Check the posts in this Thread, maybe you have the "wrong" Version of the game.

You need to see the mode selection screen.

On 11/4/2019 at 9:56 PM, WhiteByte101 said:

Hey, I followed the steps.

 

I start LegoRR.exe, it goes into 640 x 480, and shows the prompt where I choose "windowed". I press OK and then it goes back to 1080p with nothing happening :/

Check my post before.

I think it could be the same problem.

Your game crashes right after the start.

 

If you cant find a solution, send me a direct message!

Share this post


Link to post
Share on other sites
ImmortalHeir

You guys make this world amazing! 

Here's where I'm at:

1. Downloaded/installed successfully (not from CD)

2. Followed the dgVoodoo guide:  https://www.rockraidersunited.com/guides/lego-rock-raiders/run-lego-rock-raiders-with-dgvoodoo-r7/

3. Set the compatibility as per the beginning of this thread

4. Game launches (huge improvement) but runs only in contrasting black/white. The men are blacked out and the main/mission menu is all whited out.  Another fellow on this thread had the same issue but later edited it as resolved...without posting the solution. :( 

OS: Win10
Can give other specs as needed.

Any suggestions?

Share this post


Link to post
Share on other sites
Das Glückskekschen
2 hours ago, ImmortalHeir said:

You guys make this world amazing! 

Here's where I'm at:

1. Downloaded/installed successfully (not from CD)

2. Followed the dgVoodoo guide:  https://www.rockraidersunited.com/guides/lego-rock-raiders/run-lego-rock-raiders-with-dgvoodoo-r7/

3. Set the compatibility as per the beginning of this thread

4. Game launches (huge improvement) but runs only in contrasting black/white. The men are blacked out and the main/mission menu is all whited out.  Another fellow on this thread had the same issue but later edited it as resolved...without posting the solution. :( 

OS: Win10
Can give other specs as needed.

Any suggestions?

 

My patch should work without dgVoodoo.

 

 

Share this post


Link to post
Share on other sites
ImmortalHeir
9 hours ago, Das Glückskekschen said:

 

My patch should work without dgVoodoo.

 

 

Uninstalled, cleared all files. Reinstalled, added your download file. Currently, trying to run LRR.exe doesn't bring up the drivers/modes dialog window. Just goes black momentarily then refreshes.

Where can I find a "proper" LRR.exe and LegoRR.icd that works with your patch? My LRR.exe is 752 kb and LegoRR.icd is 720 kb (which doesn't match screenshots I've seen). I think I saw a download in a different guide but I don't want to cross-contaminate solutions. Thanks!

Share this post


Link to post
Share on other sites
Das Glückskekschen
4 hours ago, ImmortalHeir said:

Uninstalled, cleared all files. Reinstalled, added your download file. Currently, trying to run LRR.exe doesn't bring up the drivers/modes dialog window. Just goes black momentarily then refreshes.

Where can I find a "proper" LRR.exe and LegoRR.icd that works with your patch? My LRR.exe is 752 kb and LegoRR.icd is 720 kb (which doesn't match screenshots I've seen). I think I saw a download in a different guide but I don't want to cross-contaminate solutions. Thanks!

Send me a direct Message.
I can't, because you haven't enabled it yet.

Share this post


Link to post
Share on other sites
ImmortalHeir

Yeah sorry dude...it's not enabled and crawling all over settings and Invision Community support, still can't figure how to enable messages. >:(  I'll drop you a message once I figure it out. Just hoping it hasn't been disabled for non-admins.

Share this post


Link to post
Share on other sites
aidenpons
On 3/25/2020 at 2:02 AM, ImmortalHeir said:

Uninstalled, cleared all files. Reinstalled, added your download file. Currently, trying to run LRR.exe doesn't bring up the drivers/modes dialog window. Just goes black momentarily then refreshes.

Where can I find a "proper" LRR.exe and LegoRR.icd that works with your patch? My LRR.exe is 752 kb and LegoRR.icd is 720 kb (which doesn't match screenshots I've seen). I think I saw a download in a different guide but I don't want to cross-contaminate solutions. Thanks!

 

Here:

https://www.rockraidersunited.com/files/lego_rock_raiders/resources/lrr-masterpiece-edition-exe-r249/

LRR flat-out will not run on Win10 unless the size of LegoRR.icd is 0 kB (which indicates no disc protection). No amount of graphical shenanigans will get it to work if that is not met.

 

Share this post


Link to post
Share on other sites
ImmortalHeir
On 3/24/2020 at 1:25 PM, Das Glückskekschen said:

Send me a direct Message.
I can't, because you haven't enabled it yet.

 

7 hours ago, aidenpons said:

 

Here:

https://www.rockraidersunited.com/files/lego_rock_raiders/resources/lrr-masterpiece-edition-exe-r249/

LRR flat-out will not run on Win10 unless the size of LegoRR.icd is 0 kB (which indicates no disc protection). No amount of graphical shenanigans will get it to work if that is not met.

 

 

Thanks guys - tried with the new files, but alas no dice. When I run LRR as admin, the resolution changes to the low res and at least I do see the modes/size dialog window. But no matter if I click full or window (using 3D HAL), when I click ok, the screen goes black like it's going to kick off, but then refreshes back to the original resolution and nothing happens. 

Previously this is where I ran the dgVoodoo fix and at least the game would run, but in the horrendous black/white contrast. Thanks for sticking with me guys...thoughts on next steps? 

P.S. For what it's worth - if I run using the RGB emulator, it actually boots in full color (no music & some lag), but it crashes when trying to start the first mission)
P.S.S. Full transparency, I didn't install Direct X 6 when I was asked during installation (figured it's obsolete now). I've tried reinstalling, but never got prompted for the direct X install again. Hoping that doesn't make a difference.

Share this post


Link to post
Share on other sites
Haz

Seems like I joined in at the same time. I'm also having the same high contrast dgVoodoo problem.

Share this post


Link to post
Share on other sites
Das Glückskekschen
12 minutes ago, Haz said:

Seems like I joined in at the same time. I'm also having the same high contrast dgVoodoo problem.

My Patch doesn't need dgVoodoo.
If it doesn't work, I can't help you at the moment.

I stay in contact with ImmortalHeir, if we find a solution, I will post the solution here.

Share this post


Link to post
Share on other sites
Haz

Thanks, but I'm unable to get it to launch without crashing, unless I use dgVoodoo. I tried with your patch just in case, but no dice :( thanks though

Share this post


Link to post
Share on other sites
miketheboy89

I'm able to get the game to work with this solution, until I click on the first level in the game, then the game crashes and I can't get any further. Any suggestions?

Share this post


Link to post
Share on other sites
aidenpons
2 hours ago, miketheboy89 said:

I'm able to get the game to work with this solution, until I click on the first level in the game, then the game crashes and I can't get any further. Any suggestions?

 

Sounds like the cutscenes are causing the game to crash. Try removing the CD from your drive (if you still have it) - or the cutscene files from Data/AVI (just don't delete any .flh files), or replace your LegoRR1.wad with this which forces the cutscenes to not play.

 

cf:  https://www.rockraidersunited.com/guides/your-master-guide-to-get-lrr-to-run-r12/  which also contains handy common troubleshooting problems

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.