Jump to content
Das Glückskekschen

[SOLUTION] Lego Rock Raiders on Windows 10

Recommended Posts

Honeywithfangs
Posted (edited)

Heya, I'm back again!

 

So, I've got the game working (Thank you so much for being patient and getting me this far!!!)

 

New problem

 

The game appears to launch in black and white. Except when an animation happens, then the area of the screen with the animation runs in full colour. I've looked around for a guide to fix this but I'm not certain what I'm looking for XP

Edited by Honeywithfangs
I managed to fix the original problem

Share this post


Link to post
Share on other sites
mattbatcraz
On 4/28/2019 at 11:29 PM, aidenpons said:

Have you run through all of the steps here? There's a decent amount that needs to be done...

 

... Also, what's your OS?

Yes I'm aware and have followed the steps in this guide as well, I am running Win10.

 

Update: after watching the load sequence a few times, it seems the loading bar freaks out at the end and moves back and forth before the game crashes out.

Share this post


Link to post
Share on other sites
Thorinair

I am close, like really really close to get this to work!

I have the game running on Windows 10, in windowed, without lag, with decreased desktop resolution (so it matches the game), cinematics play, music plays, etc. Just one little thing left: Getting this specific "window repositioning" fixer to work. You see, to get the cinematics running, I have to run the game in Windows XP (SP2) compatibility, yet this is the ONLY compatibility setting that doesn't work with this fix from this post.

When running the fix without admin, the window simply flashes, but doesn't change its location. When running the fix with admin, the window's location does go into the right spot in the screen, but the image remains permanently frozen. The fix works perfectly fine even without admin with all other compatibility modes, but ofc the cinematics don't work in those...

Any chance that you could maybe update this fix so it works when the game runs in WinXP compatibility as well?

EDIT: Part of the problem seems to be that when setting to Windows XP compatibility, the game will run in admin mode regardless of anything.

EDIT2: Solved! If anyone else runs into this issue, the best fix is to open the command line (cmd.exe) as administrator, navigate to the folder your game is in and after running the game, start the rr-fix.exe through the command line! This will avoid the Windows 10 prompt for admin permissions and avoid bricking (pun intended) the game.

Share this post


Link to post
Share on other sites
Pyrogeth

Hello, newbie here.

 

I've followed all the fixes on here several times.

 

I'm running windows 10, but I have tried the windows 98/me compatibility as well as xp/sp2.

 

in every situation my resolution will drop to the correct resolution then turns black then changes back to my default resolution without starting the game.

 

I don't have enough time to right-click the fix in that small window of opportunity.

Share this post


Link to post
Share on other sites
DIRTYGIRTY45

can you make a video tutorial? it is still not working

Share this post


Link to post
Share on other sites
Das Glückskekschen
On 6/10/2019 at 7:40 AM, DIRTYGIRTY45 said:

can you make a video tutorial? it is still not working

I don´t think that will help..
I know that my fix doesn't work on all modern Systems.
Some users had send me their rr files, on my two systems it works perfectly, on their systems not.

Same questions as usual.. which version do you have?

On 6/7/2019 at 5:21 PM, Pyrogeth said:

Hello, newbie here.

 

I've followed all the fixes on here several times.

 

I'm running windows 10, but I have tried the windows 98/me compatibility as well as xp/sp2.

 

in every situation my resolution will drop to the correct resolution then turns black then changes back to my default resolution without starting the game.

 

I don't have enough time to right-click the fix in that small window of opportunity.

Share this post


Link to post
Share on other sites
Jamesjayzero

Hello. Thanks for the solution. But i have a problem ofmy own with it. The text in the game is all clustered. My guess is probably because it's a different language (russian) so i may just need to find the english version.

Share this post


Link to post
Share on other sites
Das Glückskekschen

Try to re-install it, in english. When your game-cd has that language...
If not, I can Upload my files for you.
I hope that I don't get  banned or something for this. 😞

Share this post


Link to post
Share on other sites
Jamesjayzero

Don't worry. I've found english version somewhere. But now i don't have any cutscenes, and the game sometimes crashes.

Share this post


Link to post
Share on other sites
aidenpons
10 hours ago, Jamesjayzero said:

Don't worry. I've found english version somewhere. But now i don't have any cutscenes, and the game sometimes crashes.


"Game has no cutscenes" is simply due to them not being in the game folder :P

If you still have the disc, you can copy them from Data\AVI on the disk to Data\AVI in your LRR directory. Alternatively, download them here:

https://www.rockraidersunited.com/files/lego_rock_raiders/resources/rock-raiders-avi-cutscenes-r296/

and extract those into your Data\AVI folder.

You may also need to download and install this, the codec for playing the videos:

https://www.rockraidersunited.com/files/lego_rock_raiders/resources/indeo-iv50-avi-codec-r111/

but I am unsure how necessary this is.

 

 

As for "the game sometimes crashes," it's LRR, it does that. Sonic Blasters are a known problem, and the game sometimes just breaks and blows up. For me, this isn't any more than three times an evening though (usually...), so if you can't complete levels before it crashes you may have a problem.

 

 

(Cf. also this)

 

 

 

Share this post


Link to post
Share on other sites
Jamesjayzero

All worked, thank you. Had trouble finding system directory, but now it all works.

Share this post


Link to post
Share on other sites
AlphaEagle231

Im Having issues again, I did what the instuctions said but however, everytime i try to launch the game it just instantly stops working without even launching

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.