Jump to content
McJobless

Idleness Syndrome: What is the Root Cause?

Recommended Posts

aidenpons

Something else to toss in is that if each RR has a tasklist, then going into First Person view may either pause the tasklist or erase it. If the latter, it may explain why Idleness Syndrome can be temporarily prevented by doing some drilling in First Person view.

 

Also,

Idleness Sydnrome is... about... four? times worse on maps that have inacessible objects - eg Water Lot of Fun, or Fire 'N' Water. Try to build a base on both sides simultaneously and your LRRs work incredibly slow.

That's probably the pathfinding playing up as per Cirevam's notes.

 

So, ways in which map designers and players can alleviate Idleness Syndrome:

  • Small maps
  • Small number of LRRs
  • Using ptl shenanigans to make sure the only ore that spawns is the ore specified in Cror.map (& makes for interesting gameplay)
  • Teleporting out idle raiders
  • Using as many vehicles as possible, as opposed to raiders
  • No ravines or impassable areas

Share this post


Link to post
Share on other sites
aidenpons

After playing Time Raiders, I got the Disappearing Raider glitch to go off (yay?)

 

I noticed that not only did my raiders disappear, but so did the Rock Monsters. Trying to "Go to Notification" of where a monster was caused the camera to go off the map entirely (not even the classic rock backwall), and I couldn't find where it had gotten to (and in one case couldn't get it back, and had to quit entirely).

However, my special raiders (the heavily modded Engineers, Mechugs), did not disappear. Instead they just slid around glitchily trying to find their target. If I turned on Action Stations!, they'd go over and try and shoot a slug; except that no projectile came out and thus no damage was dealt.

 

Furthermore, Slugs got into their own 'idleness syndrome;' they would wander over to one building, try and suck it, then as if I'd turned the power off they'd go and find another building to suck (but the power was still on). I don't think I lost any crystals to them, but I couldn't be sure.

EDIT: That's just broken TR slugs :P

 

What is very odd is that this disappearing glitch was not caused by loading any vehicles. I suspect it was caused by modded Rock Monsters doing really stupid things with boulders, but I can't be sure.

 

As noted beforehand, vehicles continued to work fine; despite zero functional minifigures I managed to strip-mine the crystals needed to win.

 

 

I've also noticed that if I get this glitch, quit, and start a new level, the glitch remains; all my raiders are gone. Restarting the entire computer fixed it, but restarting LRR might work just as well.

 

 

 

 

edit: grammar

Edited by aidenpons

Share this post


Link to post
Share on other sites
aidenpons

I found something else about the disappearing raiders glitch. If you teleport a new raider down, they will stay in the map as long as they have no task to do. Telling them to 'move' counts as a task and they will glitch into another dimension.

 

If there are things to do on the map, as soon as they teleport down they'll start doing one of those tasks and glitch out.

 

 

Also.... uh.... this happened:

 

 

Running several mods; my Ice Sanctuary custom map in addition to Hover Scouts Can Do A Lot Of Things, which explains why there's actually one there. :P (No, I still can't get them to upgrade to carrying...)

 

But as for why the LRR warps in and out of existence, and why one raider is permanently stuck in the throw cycle (there was a monster there before the monster also glitches off the map)... well, that's the point of this topic?

Share this post


Link to post
Share on other sites
aidenpons

I ran LRR for two days on 3x speed (46 hours according to the level timer, but that clearly doesn't account for speedup): there was nothing on the level (Air Raiders) save initial buildings & a couple of walls knocked down to prevent landslide damage to buildings, and noticed a couple of things:

 

a) the game didn't crash from landslides defined in Fall.map (random landslides are a matter yet up for grabs)

b) LRRs would refuse orders (they would move to an area but not shovel it despite me telling them to

c) LRRs (well, LRRs on supa-dupa Hover Scouts) would do things that were disabled in Priorities (eg shovel rubble or pick up Ore)

d) LRRs would automatically shovel the most recent landslide that occurred

e) initially when there were a bagillion landslides in the map (some inaccessible), Idleness Syndrome was so severe I had to force-power my Support Station (debug key END) or else I'd lose

f) however, as the landslides were cleared away it returned to normal

 

I also discovered

g) tasks that were no longer necessary were still in the queue. I saw this by:

- Use the Get Driver function on a vehicle

- Grab a nearby raider doing something else and tell him to go in. He gets in fine.

- Teleport down a new raider

- New raider goes to train as a Driver at the Support Station: this only happens if they need to get into a vehicle (else they don't train automatically

- Game continues as normal

 

Make what you will of that....

Share this post


Link to post
Share on other sites
aidenpons

Strange... I've never seen this before.

 

In a map I'm working on, essentially you start with a base and lolnope out of there as the erosion gobbles it all up.

I managed to teleport up some buildings and gain their crystals, but when I gave the final leave order to my STTs some of them still had crystals in them.

 

I find the safe spot, start building a base, and give a manual order to my STTs to drop their crystals.

From here, nobody picks up those crystals. It's almost like they don't exist: perhaps the tasks were not properly generated upon dropoff? Perhaps so many lost tasks from ore being eaten by lava had a role to play?

Manual orders of pick up those crystals do nothing. Yet all the other crystals are fine...

 

I've never seen this before...

Share this post


Link to post
Share on other sites
aidenpons

TL;DR Read the paragraph below the flashy lights. The rest is just explanation and comments

 

 

This is... what.... sixtuple posting? Oh well. But:

 

:light1:I now have a theory for what causes Idleness Syndrome! :light1:

 

 

My theory is that each frame the pathfinding algorithm tries to make a path for absolutely every conceivable task that needs to be done on the map (as we know "move to X" is a different task to "pick up X;" that in itself explains a lot of things) However, if this takes too long due to too many RRs or too many pieces of ore on the map, the game can't complete all the pathfinding before the next frame occurs and it has to start over again. Which it will never finish. Etcetera...

 

 

This explains:

- why Idleness Syndrome only affects some RRs (the algorithm can complete everything for some RRs but not others before it has to restart)

- why it is more frequent with resources on map and raider count

- why it goes up with map size (=> more the pathfinding algorithm has to crunch through)

- the relation between the NERPs, framerate, and the game

- why if there is nothing to do and something becomes available, LRRs will immediately run off quite literally the frame it becomes available; it makes sense that the game checks for tasks to do every frame

- why the things we do to reduce Idleness Syndrome work (less raiders / less resources / smaller map size)

 

 

This does not explain:

- why vehicles are unaffected (however as evidence by Disappearing Raiders, vehicles are clearly something different...)

- Separation Anxiety, which is a less severe form of Idleness Syndrome that occurs when you have two bases crossed by an inaccessible rift (eg Fire 'n' Water, if you don't teleport up your base on the first side before building a second)

- lag that occurs due to pathfinding reported previously in this thread (but keep in mind this is very rare)

 

 

This may be a bad idea because:

- one would think the game would wait for the pathfinding and task assignment algorithm to finish before advancing to the next frame

- one would think the pathfinding algorithm would only generate a path for the first raider to do the first task, second raider to do the second task, third raider to do the third task, etcetera; as opposed to all paths for the first raider, all paths for the second raider, all paths for the third raider

 

 

This may be a good idea because:

- the game clearly has no "do close tasks" prioritization but it is possible that attempts at implementing this were made; the only way to know which is the closest task is to check the distance for all the tasks and check, which requires generating paths for all tasks; the distance check clearly isn't implemented but we know that the last 72 hours of development were spent between the devs and the QA team; the QA team would find a game-breaking bug and the devs would fix it, rinse and repeat for 72 hours before launch; so it's probable to me that something like the lack of a distance check just got put by the wayside

 

 

Share this post


Link to post
Share on other sites
Cyrem
1 hour ago, aidenpons said:

one would think the game would wait for the pathfinding and task assignment algorithm to finish before advancing to the next frame

This pretty much. It would be very unusual behaviour to abandon all calculations for the sake of keeping FPS high, and I do not believe they would have done this.

 

@Cirevam has done priority checking with epic sized maps, and the RR's prioritize mindlessly.

Share this post


Link to post
Share on other sites
SMLC

First time I played the game, I recall specifically that Water Lot of Fun was my worst experience with idleness syndrome - probably the only experience that I registered as being truly game-breaking. 

 

Attempting to build on both sides of the river (as the level designers wanted you to) was the culprit - horribly inefficient, took hours. I believe that the long, round-a-bout pathfinding that brought the cadets relatively close to the home base in the end... I think that was to blame.

 

The problem was more or less easy to solve through use of Small Transport Trucks rather than raiders on foot.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.