Jump to content
pivke

LI2GE - Lego Island 2 Game Editor 0.1.3

Recommended Posts

pivke

Hello,

you remember the old thread New MultiTool for Lego Island 2 [WIP]?

 

What happened?
Well, after 5 years, I finally finished this tool. Certainly I didn't really finish it, as I started to develop a completely new software 2 years ago. But as time went on, my spare time was getting less as I had to assume our family's demolishing company. I hope you forgive me, because I already felt bad for promising something and not finishing it. So here it is, after several weeks of hard and exhausting work.

 

LI2GE - Lego Island 2 Game Editor

Finally it's there, the official Game Edit- and moddingtool for Lego Island 2: The Brickster's Revenge. With this tool, you are now able to completely modificate your game files. The official websiteof LI2GE: www.li2ge.sourceforge.net

 

Advanced features:
-Export images in PNG, JPEG or BMP format
-Export 3d models in OBJ-format
-Export animated textures in all it single frames in PNG, JPEG or BMP format
-Export the whole file directory to your computer
-Replace any game file you want after editing

 

Screenshots

2.png

 

1.png

 

3.png

 

Download

The project is hosted on sourceforge. You can download it here: Latest version on SourceForge

 

(The project is licensed under GNU-GPL and is opensource. So you are free to modify and change it's content.)

 

Bugs , Issues & Improvements
This software is not fully tested and can contain bugs. It's more like an alpha-version for now. When you are encountering any problems or you have ideas for improvements, please feel free to contact me over SourceForge. Please use the "Support", "Tickets" or "Discussion" section on the SourceForge project page. Otherwise you are running the risk not to be noticed of me.

 

Before using this software
Please notice that this software is not fully matured for now. That means, that you should backup all the game files you want to modify before using this software. It's always possible that your files get damaged.

 

P.S.: The next days I will publish another awesome plugin to get your models back into lego islands *.msh format... :)

Share this post


Link to post
Share on other sites
jamesster

Pretty neat, the model viewer especially seems handy.

 

The colors on WIBs are a bit off, all the minifig faces are blue instead of yellow - it's nice to be able to quickly view them though, and animated:

 

73Vh4S9.png

 

Also, it'd be nice to be able to sort files alphabetically as well as by their order in the file, just to make browsing a bit easier (unless there's already a way to do that and I didn't notice).

Share this post


Link to post
Share on other sites
pivke

Thanks Terrev, glad you like it.

 

Kinda strange thing with the faces, never noticed that. Do the other WIB-animation (not faces) have wrong colors too? Maybe there went something wrong when converting them to common RGB profiles. Or possibly that color is meant to be transparent?

Would you please post this problem here: SourceForge Ticket so i can keep track of all problems and bugs?

 

The alphabetically sort is a very good idea. I know I once disabled this function when it froze the whole tool through the large data being processed. I'm gonna try to implement it for the next update. Maybe a search function would be a good idea as well?

Share this post


Link to post
Share on other sites
tomfyhr

Could you add a feature that changes the skyboxes?

 

Xiron had a post about it. 

Post: 

 

Share this post


Link to post
Share on other sites
pivke

Just like Xiron explained, the sky-colors are hardcoded in the games executable. I don't think that this feature would fit into this modding tool. When those hardcodes are more researched, it would be a good idea to develop a small tool to change this and several other options.

Share this post


Link to post
Share on other sites
Xir
1 hour ago, Terrev said:

The colors on WIBs are a bit off, all the minifig faces are blue instead of yellow - it's nice to be able to quickly view them though, and animated:

If I'm not mistaken, what happened is that the program is reading it like RGB instead of BGR (reverse endian) like it should be.

 

@pivke_newaccount - exporting the .tga files flips them vertically; also, may I suggest an "open file" command or button for the next build? It would be nice to not have to close and re-open the program just to check a different file.

Lastly, I'm getting this really weird bug; If my bod/bob files are under "C:\Program Files (x86)\LEGO Media\LEGO Island 2\_data" (my installation directory), when I open the model viewer the model blinks and vanishes forever, but if I open the file anywhere else like my desktop or on an external hard drive it works perfectly fine. Admin/ownership rights are not the issue, I made sure of that.

Share this post


Link to post
Share on other sites
pivke

@Xiron

I need to check that with RGB and BGR. Will be fixed with the next update. Flipped TGA will get fixed too with the next update. No big deal here.

 

21 minutes ago, Xiron said:

 

@pivke_newaccount

Lastly, I'm getting this really weird bug; If my bod/bob files are under "C:\Program Files (x86)\LEGO Media\LEGO Island 2\_data" (my installation directory), when I open the model viewer the model blinks and vanishes forever, but if I open the file anywhere else like my desktop or on an external hard drive it works perfectly fine. Admin/ownership rights are not the issue, I made sure of that.

For this moment, I can't reproduce your issue. Did you try to start the tool as administrator? Does that effect happen on other models too? When it's "blinking", try to toggle bounding box and tell me, if the bounding box is blinking too.

Share this post


Link to post
Share on other sites
Xir

Starting the tool as administrator will give me a crossed out circle (the unavailable cursor icon) when I try to drag a bod onto the program, so no go there.

Ticking any of the options like bounding box will not cause anything to show either.

*pokes more*

Huh... that's strange, by pure luck I had it load once without problem, reloaded file and it did the vanishing act again.

 

A clip of the issue can be seen here anyhow: https://youtu.be/csHsc2M0-vw - you can see how at 0:10 it quickly disappears.

Share this post


Link to post
Share on other sites
pivke
1 hour ago, Xiron said:

Starting the tool as administrator will give me a crossed out circle (the unavailable cursor icon) when I try to drag a bod onto the program, so no go there.

Ticking any of the options like bounding box will not cause anything to show either.

*pokes more*

Huh... that's strange, by pure luck I had it load once without problem, reloaded file and it did the vanishing act again.

 

A clip of the issue can be seen here anyhow: https://youtu.be/csHsc2M0-vw - you can see how at 0:10 it quickly disappears.

The problem comes from the viewer (libQGlViewer). Sometimes it wont center the model in the middle of the view as it should. In your case, the model (all renderings) will appear "behind" the camera (z+).

 

Please first try to scroll in our out, it should appear then. If not, first double click the right mouse button, then double click the middle mouse button.

 

Noticed this problem for myself too. Looks like I have to contact the programmer of libQglViewer to solve this problem. Gonna fix it aswell in the next update.

 

3 hours ago, Xiron said:

 

@pivke_newaccount - exporting the .tga files flips them vertically

Can someone confirm this behaviour? Please provide an example. I can't reproduce this issue.

Share this post


Link to post
Share on other sites
pivke

Update 0.0.2
Just fixed some little bugs and issues like WIB animations and updating-system.

Share this post


Link to post
Share on other sites
pivke

large_fix2.png

 

Added a search function and alphebetically sorting by clicking on the row of the table. Those functions will be available with the next update, coming the next days.

Share this post


Link to post
Share on other sites
tomfyhr

Are any of the models deformed? I remember that the slug model was not correct when it was extracted from the game´s archive. 

Share this post


Link to post
Share on other sites
pivke
1 hour ago, tomfyhr said:

Are any of the models deformed? I remember that the slug model was not correct when it was extracted from the game´s archive. 

Can you please provide an example?

 

Mesh files will be exported 1:1 from the archives. Until now I didn't perceive any issue with mesh files. Please keep in mind that some mesh files are holding additional information like animation. Thereby those models possibly look "deformed". For example: ambulance_LOD1.msh or helicopter_LOD1.msh. 

Share this post


Link to post
Share on other sites
tomfyhr

Yes, you´re right. I assume that there isn´t a way to export animations, is there? 

 

The model was clustered together, instead of having a vertical shape. The same was present in other creatures on Ogel. Is it possible to make the model non-deformed? 

 

I can´t remember the name of the file of the top of my head for the time being. The model should be called slug, but I am not sure. 

Share this post


Link to post
Share on other sites
pivke
41 minutes ago, tomfyhr said:

Yes, you´re right. I assume that there isn´t a way to export animations, is there? 

For now, nobody was able to crack up the "GTOM"-section inside the *msh-file. Therefore, no, for now there is no possibility to export animation.

 

 

43 minutes ago, tomfyhr said:

Is it possible to make the model non-deformed? 

LI2GE exports mesh parts in several objects (for example: car tires, car windshield, car seat etc.). So you can export to *.OBJ -> Import with Blender -> Drag/Delete/Edit the parts that are wrong positioned.

 

In the near future I'm gonna try to crack the GTOM-section up. It seems to hold references to objects, together with it's position and rotation information. This will require many trial & error to see how it works.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.