Jump to content
Sign in to follow this  
Oboe Shoes

Sonic Blaster Crash Fix

Recommended Posts

Oboe Shoes

Ladies and gentlemen, I've finally been able to rid Rock Raiders of one of the last big problems that's been plaguing it. As most of you know, the Sonic Blaster has a tendency to crash the game when running on newer versions of Windows. After numerous failed attempts to edit the original files to remove the problem, I've gotten it to work by recoding most of it from the ground up, using the dynamite assets as a base. (Don't worry, I've made sure that it's visually and functionally identical to the default Sonic Blaster)

Anyway, with this, you should now be able to enjoy the ability to scare away slugs and monsters as originally intended. Maybe now we'll be able to do Back to Basics without toggling the power, eh?

 

Download here.
 

Share this post


Link to post
Share on other sites
Cyrem

Hooray! Even though I don't have this issue, great to hear you got the original blaster working!

Share this post


Link to post
Share on other sites
Oboe Shoes

Yeah, it doesn't effect everybody, though from what I've seen, I'm hardly the only one with the issue. So hopefully this'll help the other unfortunate souls out there.

Share this post


Link to post
Share on other sites
Ben24x7

Something strange happened once. I was playing in Rock raiders PC and like with most windows users (who have windows 7 and above) the game will crash once the Sonic Blaster sets off. I know you already know that bug but I came across a strange way to fix it without downloading anything.

 

All I did was go into 'Properties, Advanced options, monitor' and I changed '32 Bit' to '16 Bit'. I opened up Rock raiders again, crossing my fingers that meddling about with the screen would work. An RR dropped a Sonic Blaster and it exploded...   ...But it didn't crash!

 

If this works for everyone then no one needs this download but it gets a real pain to switch between '16' to '32' every time you want to open a recent game (and the other way around if you are going to be playing in Rock raiders or any of the other Lego games before 2005).

Share this post


Link to post
Share on other sites
Cyrem

Something strange happened once. I was playing in Rock raiders PC and like with most windows users (who have windows 7 and above) the game will crash once the Sonic Blaster sets off. I know you already know that bug but I came across a strange way to fix it without downloading anything.

 

All I did was go into 'Properties, Advanced options, monitor' and I changed '32 Bit' to '16 Bit'. I opened up Rock raiders again, crossing my fingers that meddling about with the screen would work. An RR dropped a Sonic Blaster and it exploded...   ...But it didn't crash!

 

If this works for everyone then no one needs this download but it gets a real pain to switch between '16' to '32' every time you want to open a recent game (and the other way around if you are going to be playing in Rock raiders or any of the other Lego games before 2005).

 

8|

 

Windows changes the colour mode to 16bit automatically when you run LRR as it can only run in 16bit colour mode. The only time you ever need to do it manually is when you need to run LRR in a window.

Share this post


Link to post
Share on other sites
chaq123

Ladies and gentlemen, I've finally been able to rid Rock Raiders of one of the last big problems that's been plaguing it. As most of you know, the Sonic Blaster has a tendency to crash the game when running on newer versions of Windows. After numerous failed attempts to edit the original files to remove the problem, I've gotten it to work by recoding most of it from the ground up, using the dynamite assets as a base. (Don't worry, I've made sure that it's visually and functionally identical to the default Sonic Blaster)

Anyway, with this, you should now be able to enjoy the ability to scare away slugs and monsters as originally intended. Maybe now we'll be able to do Back to Basics without toggling the power, eh?

 

Download here.

 

 

Hey so I downloaded your file, but I do not see a folder called BirdScarer in my RockRaiders Data...

All I can see is AVI (a bunch of .flh files) SAVES (save files) and SOUNDS ([sTREAMED] lots of sound files) ... so I'm wondering if you could help me find it, or if I do not have a complete version of RockRaiders?

Share this post


Link to post
Share on other sites
LimeKiller

This didn't work for me, it still crashed the game. The explosion went for a longer period before the game crashed, but it still crashed. For some reason my game runs at about 15 FPS as soon as you build the power station (before that it's fine) and only when you're not in first person mode. I have a feeling that it's because of this lag that my game crashes, as I have set off the sonic blaster successfully before I had built the power station. I saw a topic about said lag, but it wasn't much help. Sounds like there's not really a solution.

 

 

 

...sigh....

 

EDIT: I just tried it again today without changing anything, and it worked. So thanks!

Also, WTF IS WITH THIS GAME

Share this post


Link to post
Share on other sites
RCninja

I have already prepared my Rock Raiders for modding, I have put the birdscarer folder in the same directory as the application, loaded it, it crashed. I then tried it by putting the birdscarer folder in the data directory. Still crashed. I don't know what I do now? I feel I have put it into the wrong place, but I just need guidance.

Share this post


Link to post
Share on other sites
Oboe Shoes

Make sure you put the birdscarer folder in the miscanims folder, which itself is inside the data folder. There should already be a birdscarer folder in there, so either delete that first, or move it somewhere else if you want to back up the original.

Share this post


Link to post
Share on other sites
RCninja

Dude, you're the best. I feel Stupid for not knowing that. But thank you so much For making this and guiding me through it. I can now play this fantastic game. :D.

Share this post


Link to post
Share on other sites
Oboe Shoes

Not a problem. I had to deal with this for years, and was very excited when I got it to a working state, so I'm always happy to help others that have the same problem.

Share this post


Link to post
Share on other sites
aidenpons

Call my computer an absolute idiot and a lunatic, but...

 

LegoRR.exe has stopped working.

 

Unless I did something horribly wrong (Deleted old BirdScarer folder, moved your new one into MiscAnims, recompiled RR0 (and RR1). wad.

 

 

However, when I was testing it our, I did two levels. On one it didn't crash, and on the other it did. (I set off several, but staggered). When it crashed, I clicked 'Drop Sonic Blaster.' It appeared on the ground, counted down, my RR ran away, it started to explode and BAM.

 

:cry: I've shut RR several times, restarted it, re-packed the WADS, replaced the mod, and it still crashes. :(

Share this post


Link to post
Share on other sites
Oboe Shoes

Personally, I've never tried to use any of mods while recompiling the WADS, I just leave them decompiled. (See the various modding tutorials for more details.)

 

But, in theory this shouldn't really matter, so I'm a little bit confused. Unless my new birdscarer folder is being overwritten somehow, it's presumably reading it and using the files, so it may just not be working for you. Worth noting, in my case, the unmodded sonic blaster would not crash the game if it did not hit or affect anything, only if it caused a creature to turn away from it. If this is the case for you, it almost sounds like it's still getting the original files from somewhere.

 

Personally, just to cover everything, I'd try to do this without recompiling the WADs (makes future modding a lot less of a pain anyway) If it still doesn't work, it's possible the fix just might not work for you, seeing as other people don't seem to even have any problems with the sonic blaster at all, so the thing is still a bit of a mystery. However, if you still can't get it to work, you could try Cirevam's improved Sonic Blaster, which also fixes crashing problems for some people.

Share this post


Link to post
Share on other sites
alanbarr88

Hey folks, im having the same issue as Chaq123. Cant find the Miscanims folder within data. I've prepped it for modding and searched the computer for it but miscanims just ain't there 😯 any advice?

Share this post


Link to post
Share on other sites
aidenpons

Hey folks, im having the same issue as Chaq123. Cant find the Miscanims folder within data. I've prepped it for modding and searched the computer for it but miscanims just ain't there any advice?

You've tried extracting RR0.wad with the Wad Recycler?

Share this post


Link to post
Share on other sites
Oboe Shoes

Yeah, I'd double check that you went through every step correctly, and extracted the WADs and whatnot. There are many other folders inside miscanims, and they're all rather important, so something's definitely not right if the folder isn't there.

Share this post


Link to post
Share on other sites
alanbarr88

Figured out that original issue with not being able to find MiscAnims however...

I've extracted both wads, deleted the original wads then moved everything from the LegoRR00 and LegoRR01 folders into the data folder. I've then replaced Birdscarer from Data/MiscAnims with the Birdscarer from Oboe_Shoes' fix. Still no joy though. Game still crashes just as the blaster goes off.

Share this post


Link to post
Share on other sites
RockRaiderWolf

hmm well i have never had an issue with sonic blasters (on their own, too many along with other animations might still crash) so I will upload mine and maybe it will work for you. DL Here

Share this post


Link to post
Share on other sites
alanbarr88

Hmmm....had a little trouble opening the .zip Wolfy. Thank you very much for the suggestion though! I'd like to commend Oboe Shoes also, your work on the crash seems to have solved it for a lot of people!

Share this post


Link to post
Share on other sites
RockRaiderWolf

Hmmm....had a little trouble opening the .zip Wolfy. Thank you very much for the suggestion though! I'd like to commend Oboe Shoes also, your work on the crash seems to have solved it for a lot of people!

so did you ever get it open? it's possible since i was using 7zip that i may have accidently used LZMA compression instead of simple Deflate method and that gave you trouble? Anyway let me know if I need to upload a new one.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.