Jump to content
Axel

Axel's Mod 1.5 (Updated, 4/10/2015)

Recommended Posts

paperpanzer

Well, further in the mod with more crashes is actually something i expected, given that the later missions are more complex and the old LRR Engine would have a hard time with them.

 

I was thinking about the disappearance bug and it being random from machine to machine- but it could be any one of a number of things. A lot of changes went into the raiders themselves- i.e. upgrade to lvl 6, "permagone" if not teleported out manually, new idle animations. I did disable the random move factor- but beyond that and the rock fall dmg factors I haven't touched the rock raider's values in the cfg file.

 

I did have the disappearing bug again on Rock Hard, this time the Chrome Crusher was the culprit. It would be nice if the LRR client generated a crash log.

Share this post


Link to post
Share on other sites
paperpanzer

Had the vanishing bug occur again, this time on Ice Spy. Was using the SMLC at the time.

 

While others have reported the Tunnel Transport causing this problem, it works just fine over here. In my case it appears that in certain levels laser vehicles cause the problems.

 

So Ice Spy, Rock Hard, and Slimey Simple have so far been plagued with this problem. Again it seems to be random, as in other missions where laser mining is either optional (or essential) there has been no issue, such as Erode Works, Don't Panic, Explosive Action, to name a few.

 

** I'd also like to state my opinion on the Recharge Seams, having them in more than just the four or so levels in the vanilla game is great, the lasers were always underutilized. But these same wall types causing landslides? Regular seams having landslides is fine, as they can be drilled. But Recharge Seams are like Solid Rock, they cannot be reinforced.

Share this post


Link to post
Share on other sites
Slimy Slug

Ok that's actually something in common we have: it happens a lot on Ice Spy for me.  

 

In fact the first time I saw this bug was on this map and yes I was using the Tunnel Transport.  But I've noticed it happen with other things on Ice Spy, so...

The other maps that I have confirmed this bug to happen on are Recruitment, Hot Stuff, and Rocky Horror.  

 

I share your thoughts on the Recharge Seams.  Having them in many more maps encourages further use of the lasers.  

If you think the landslides are bad with Recharge Seams, you missed an earlier version of Baz's mod which had an emerge point in the seam right next to your Tool Store in Hot Stuff.  

 

I need to double check how everything works but I know that you can stop random landslides from happening on a map period.

Share this post


Link to post
Share on other sites
paperpanzer

Well, here's an interesting development- don't know if this is actually a thing or not but, I'll mention it anyways.

 

So I made the cardinal mistake of using a mining laser on Fire 'n' Water, which as you may guess, caused the vanishing bug again. However, in that particular mission I had a couple of Rock Raiders that were not lvl 5 (Or is it 6?). Anyway, all the "trained" guys disappeared as usual (coupled this time with the teleportation out sound very loudly in my left ear), but the untrained rock raiders did not, they hung around working like normal.

 

As to the trigger that sets this bug off I'm still not fully sure as to what it is, all I know right now that for me laser mining appears to be the culprit, and only on a few levels. But, either I hit a random exception to the rule or the vanishing bug has something to do with the additional upgrade level.

Share this post


Link to post
Share on other sites
Slimy Slug

Well, I figured someone had to do it.  Went through Axel's cfg included with his WADs to see if I could find the problem. 

Turns out an extra backslash where one should not have been was to blame for the insane number of random crashes.  

 

Without further ado, I present the fixed Lego.cfg file:

https://www.rockraidersunited.com/files/dl-r234/

 

This should cut down significantly on the number of random crashes.  

Other things I fixed:

 

1. Eye/shoulder view crashing.  Axel's value for FPClipBlocks was 30 when anything around 18 will cause a crash.  Dropped it back down to 16.

2. Mining lasers will now actually HIT walls for the most part.  Axel's values were beyond too high.  See my topic on this for further details.

3. Pyrite Monster will now behave as Axel intended, and not as a Lava Monster.  Enjoy.

4. Minor text fixes

5. Infinite drain rate bug fix.  @paperpanzerReported that the problem was actually caused by the usual fix, so if you have issues please let me know immediately.

 

If there's anything else that needs fixing via the cfg, I'd appreciate a heads up.

 

 

 

Share this post


Link to post
Share on other sites
pbhead

Slimy Slug, Thanks so much for editing the CFG file.

 

I recently rediscovered rock raiders, and am giving this mod a try, and I /think/ I did everything right... which, given that this morning I had no idea what WADS was, and here I am decompling it, swapping out the CFG file and recompling it... i could very well be doing something wrong. 

 

But, for me at least, the first person view still crashes with your CFG file. 

 

I am using the https://www.replaying.de/files/lego-rock-raiders-patch-windows-7-8-1-10/  patch, and voodoo and all to play on windows 10, as opposed to am emulator, maybe that has something to do with it?  And then of course installing the mod, then the mod patch, and then wads tool decompile on the mod patch, then swapping out the file, and recompiling...

 

I saw there was a sound mod for this mod, but i downloaded it, and the instructions involve EDITING the CFG file, and that seemed a little advanced for now, especially since this cfg file is much bigger than the one I assume that sound mod expects. So, later.

 

Seriously though, this mod is amazing, and this community is amazing and i am quite excited to have found it, and be playing this game again. :D

 

edit: also got a crash when upgrading the upgrade station to lv 2.

 

edit edit: hmm, first person only crashes when I was running it in windowed mode... of course alt tabing to type this message seems to have frozen full screen mode.  So maybe things are broken on my end.

 

edit edit edit: after messing around with voodoo and compatibility settings, i managed to get first person mode not crashing in windowed mode! I have no idea what caused it though! hurray for random clicking!

Share this post


Link to post
Share on other sites
Slimy Slug

Curious.  Does eye view crash for you in the original game at all?  Or in Baz's mod for that matter.  

 

The crash when upgrading the Upgrade Station to level 2 might have been random, unless it's happening consistently for you.

 

Either way, you're quite welcome, pbhead.  It's a bit puzzling that nobody else tried fixing the cfg before now.

Share this post


Link to post
Share on other sites
pbhead
22 hours ago, Slimy Slug said:

Curious.  Does eye view crash for you in the original game at all?  Or in Baz's mod for that matter.  

 

The crash when upgrading the Upgrade Station to level 2 might have been random, unless it's happening consistently for you.

 

Either way, you're quite welcome, pbhead.  It's a bit puzzling that nobody else tried fixing the cfg before now.

 

Well, eve view works just fine now, and the upgrade station crash did not reproduce when I tried. 

 

However, I have yet to beat the first mission, because the crashes are really bad. Not crashes really, just freezes, the game is still definitely going the screen just isn't updating. And then it sometimes crashes.  It is rare enough that I am able to get quite deep into the mission before it happens usually, but it is common enough that it ends me before I can get 30 crystals.  If I try to play in full screen and alt tab, and then go back, it happens every time instantly though, so I assume it is something wrong with my settings somewhere.   

 

edit: I got a seemingly more stable set up by upgrading Voodoo the the 2.55 version, at the cost a slightly zoomed in window which prevents me from seeing my energy crystal and ore count.  Which is not a bad trade at all.  managed to get though the first 3 missions, with only 1 random crash. :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.