Jump to content
Dowe

RR doesn't run on Windows 7 (have tried the d3drm.dll)

6 posts in this topic

Dowe    0
Dowe

So, I downloaded RR from theisozone (yes, sorry for being a pirate...), burned it onto a disc and installed it. Tried to play it, and the missing d3drm.dll error came up. Did a quick search on the web, and I ended up copying the d3drm.dll file from the disc and put it in the game's directory. Now, however, it tries to run the game but a simple "LegoRR.exe has stopped working" appears. Why is this? Does it have anything to do with it being a pirated copy? Complete newbie, sorry

Share this post


Link to post
Share on other sites
Xir    2,247
Xir
Quote

Does it have anything to do with it being a pirated copy?

Yes, and soon you'll get Windows.exe has stopped working.

 

What's your GPU (graphics card)?

Share this post


Link to post
Share on other sites
Jessietail    2,535
Jessietail
33 minutes ago, Dowe said:

Does it have anything to do with it being a pirated copy?

the only inherent issue with pirating isozone's upload is that the redbook music in that is kinda corrupted for some weird reason, seems like it was ripped from an already-pirated CD copy so I guess it's gotten pretty f****ed up. some versions of Rock Raiders have that protection stuff that won't run the game without the disc but probably none of the copies floating online have that issue.

 

if you're getting a crash message it probably isn't an issue with your GPU, that usually just results in it closing instantly with no message.

 

 

edit: isozone's version has a 752 KB exe from 9/27 and a 720 KB ICD from 10/11, what version does this line up with? not any of the ones cyrem listed in that one topic - maybe it's a mashup but none of them have an exe over 720 KB

 

edit 2: some stuff is slightly different but it mostly seems to be a bunch of garbage blank data at the end of the exe? ok then sure

Share this post


Link to post
Share on other sites
Dowe    0
Dowe
16 minutes ago, Xir said:
  Reveal hidden contents

Does it have anything to do with it being a pirated copy?

Yes, and soon you'll get Windows.exe has stopped working.

 

What's your GPU (graphics card)?

It's quite an old laptop I'm using at the moment. A Mobile Intel® Graphics Media Accelerator 4500M, apparently.

Share this post


Link to post
Share on other sites
Jessietail    2,535
Jessietail

well I can't get this version of the game to run at all even with all the same settings as my normal copy, so it might actually be because of it being pirated - specifically from it being a s*** rip.

Share this post


Link to post
Share on other sites
Dowe    0
Dowe
3 minutes ago, Jessietail said:

well I can't get this version of the game to run at all even with all the same settings as my normal copy, so it might actually be because of it being pirated - specifically from it being a s*** rip.

Ah. Oh well, thanks for the help anyways.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×