Jump to content
Jeff

[Fix] Low Framerate On Windows 8

7 posts in this topic

Jeff    33
Jeff

...and Windows 10 maybe? I still use 8.1.

 

I noticed something strange with Lego Island 2. Here is my framerate in fullscreen mode

YdFoY9Z.png

 

...and this is my framerate with the windowed mode mod.

oIhEpwk.png

 

So what gives? My computer is clearly fast enough for this old game.

As it turns out this is a common issue that began with Windows 8. Games that use old versions of DirectX (7 and lower, I think) got the shaft when it came to backwards compatibility. Fullscreen mode wrecks the framerate on them.

 

Fortunately it is possible to fix!

(Spoilered for lots of images)

Spoiler

1.) Download and install the Microsoft Application Compatibility Toolkit. (Ignore the "this is no longer supported" message. This version works fine.)

 

2.) Open "Compatibility Administrator (32-bit)". Yes the 32-bit version because Lego Island 2 is a 32-bit application.

It looks like some sort of scary database interface, because it is. But what we're doing is simple.

 

3.) Click the Fix button

gQ6tHMs.png

 

4.) Give your fix a name, browse for your LEGO Island 2.exe file, and click Next.

088GIDY.png

 

5.) Ignore this screen and click Next. The game seems to work fine without any of these compatibility modes.

kgiKBq6.png

 

6.) Search for and check "NoGDIHWAcceleration". Just start typing and it will jump straight to it. You can click Test Run... to ...run a test and see if it worked.

gcdcGR8.png

 

7.) Click Next. Ignore the next screen and press Finish.

 

But we're not done yet!

 

8.) Now click the Save button (to the left of the Fix button).

 

9.) Give your database a name...again.

h8c0hme.png

 

10.) Save your .sdb file somewhere. It doesn't matter what you call it or where you save it. The game's folder is a good place though.

 

11.) Right-click on your database and click Install. Then click okay.

YYYMvRR.png

 

12.) Get some toast for your new buttery smooth framerate.

XXHbBze.png

 

You can delete your .sdb file if you want. The fix will just work from now on when you start the game. But it won't work if you rename or move your .exe file.

 

 

Notes:

- I wrote this on the pcgamingwiki page first. I thought it might be helpful to post it here too.

- I can't remember exactly how I learned this. Probably from here, under the troubleshooting heading.

  • Like 1

Share this post


Link to post
Share on other sites
Terrev    6,826
Terrev

This is a bit of a side note, but for people who might wonder why the windowed mode screenshot shows 207 FPS, while the final screenshot in your post shows 60:

 

LEGO Island 2 is normally capped at 60 FPS. Windowed mode (which is also tied to a bunch of developer mode options) disables the cap, but many things in the game are directly tied to the framerate instead of the passage of time, and break horribly when the framerate gets too high (for example: the physics in Desert Speedster become so broken it's unplayable). Then there's the biplane game, which doesn't even work properly at 60 FPS - it's most playable around 30-40. Island Xtreme Stunts has the same problems, but doesn't have a framerate cap and is thus usually broken by default on modern computers, so you have to find other ways of locking it to make the game work properly (like forcing vsync on in your graphics control panel).

  • Like 2

Share this post


Link to post
Share on other sites
Jeff    33
Jeff

Thanks for the explanation, Terrev! I thought maybe the lower framerate at the end would be confusing, but I also figured people would realize 60 is an ideal rate on most monitors.

Share this post


Link to post
Share on other sites
Robb    10
Robb

Actually it seems the game is not capped to 60fps, but rather just uses v sync, because it runs at 120fps on my 120hz monitor.

 

In fact with that framerate on Win 8, the game is probably more playable than it is at a solid 60/120.

Share this post


Link to post
Share on other sites
Jessietail    2,535
Jessietail

is anything besides the biplane game broken at 60fps?

Share this post


Link to post
Share on other sites
Terrev    6,826
Terrev
1 hour ago, Robb said:

Actually it seems the game is not capped to 60fps, but rather just uses v sync, because it runs at 120fps on my 120hz monitor.

 

In fact with that framerate on Win 8, the game is probably more playable than it is at a solid 60/120.

Good to know. I don't think I've had monitors at anything but 60hz, or if I did it was as a kid, when of course I didn't pay any attention to such things.

 

40 minutes ago, Ringtail said:

is anything besides the biplane game broken at 60fps?

Not that I know of...

 

What was the most common monitor refresh rate back in 2001 anyway? Also might be worth noting Silicon Dreams was based in the UK... Did they have different standards than the US? I don't know enough about the history these things to come to any conclusions.

  • Like 1

Share this post


Link to post
Share on other sites
Robb    10
Robb

 

On 2/25/2017 at 8:40 PM, Terrev said:

Good to know. I don't think I've had monitors at anything but 60hz, or if I did it was as a kid, when of course I didn't pay any attention to such things.

 

Not that I know of...

 

What was the most common monitor refresh rate back in 2001 anyway? Also might be worth noting Silicon Dreams was based in the UK... Did they have different standards than the US? I don't know enough about the history these things to come to any conclusions.

 

Well I know here in UK our TV's ran at 50hz because of PAL format, but I'm fairly sure CRT monitors had higher, though I can't remember for sure. I know that PAL games typically were locked to either 50fps or 25fps. Instead of 60 or 30 like in the US.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×