bphillips09

I recreated Lego Island in Unity 5

Recommended Posts

Xir

I can give you a hand on character models (see my current avatar)

Share this post


Link to post
Share on other sites
someswedish

Though some of the buildings aren't correct (like the jail and the hospital) and if you walk into any building, you stick to it like glue, overall i think you did a decent job with this.

 

I do like that some of the locations do change what music is playing, like the original game.
 

Share this post


Link to post
Share on other sites
Xir

Okay, so I tried it out. I'm liking it thus far, I look forward to the progressment.

My initial thoughts on speed was that walking was to slow but running was to fast, but then when I decided to let myself walk for a bit longer I was like "Well this is nice, you really get to enjoy the scenery at this pace" :P (no sarcasm in the nice). I think it may leaning more towards that the running needs slowdown (or limiting) moreso than a walk speed increase.

My second comment is that distant water is too blaring white at places, like when you look to your right when you spawn at the info center, I'm like "am I even looking at water?" - all I see is white.

 

8 hours ago, bphillips09 said:

I haven't begun messing with building interiors yet, but I don't think that will be too hard (except for the fact that they are so low-res).

6 years ahead of ya, I've already got all the rooms readily available back in 2010, and objectless/NPCless too! I've actually just gone and added a score-cubeless version of that one room to the collection if you're interested in adding your own cube.

https://www.dropbox.com/s/jwuqd7by1462toz/LIInteriors.zip?dl=0

 

 

8 hours ago, bphillips09 said:

I'm considering taking on the task of recreating the entire game. The hardest part would probably be the animations and the actual character models. As of now, all I have in relation to characters are the faces and a few miscellaneous body parts.

Sound like a lot of work, don't let singlemaness be its downfall. We're here to help if you need it!

Share this post


Link to post
Share on other sites
Wognif

So far, other than the glare like Xiron mentioned (which also is present on the island at some places/angles) its looking pretty good so far!
I do have one question though: What's with all the random models at the race track?

Also, even though I figured you put the NO PIZZA sign at the cave to block it off until you get a cave model, I thought that was pretty funny.

Share this post


Link to post
Share on other sites
bphillips09
1 hour ago, Wognif said:

So far, other than the glare like Xiron mentioned (which also is present on the island at some places/angles) its looking pretty good so far!
I do have one question though: What's with all the random models at the race track?

Also, even though I figured you put the NO PIZZA sign at the cave to block it off until you get a cave model, I thought that was pretty funny.

I was just importing all the objects I could find while I searched for the other missing objects, and decided to just leave them there haha. No real reason for them to be there.

  • Like 2

Share this post


Link to post
Share on other sites
Xir

Haha, I thought so that the race track was your dumping ground. :P

 

 

Btw, as for audio tracks, the ambient noise that plays at the pizzeria isn't suppose to also play at the post office & superstore if I'm recalling correctly, as well, doesn't the 'park' song play atop the mountain?

Oh, and the musics doesn't loop. ;P

Share this post


Link to post
Share on other sites
bphillips09
23 hours ago, Xiron said:

Haha, I thought so that the race track was your dumping ground. :P

 

 

Btw, as for audio tracks, the ambient noise that plays at the pizzeria isn't suppose to also play at the post office & superstore if I'm recalling correctly, as well, doesn't the 'park' song play atop the mountain?

Oh, and the musics doesn't loop. ;P

Yeah unfortunately as of 4 days ago Lego Island doesn't launch on my PC anymore, so I haven't been able to fine-tune the audio colliders or anything. And I also haven't figured out the best way to loop the audio tracks using the fading method I'm using. Currently, if I loop them, when you enter another area it doesn't fade to the next song until the current song is finished, so I'll have to find a way around that.

Share this post


Link to post
Share on other sites
Xir

Aaah, okay. That splains it.

 

Island not working eh, what's your OS, Windows 10?

Share this post


Link to post
Share on other sites
bphillips09
3 minutes ago, Xiron said:

Aaah, okay. That splains it.

 

Island not working eh, what's your OS, Windows 10?

Windows 10 64-bit with an Nvidia GTX 970

It worked perfectly until a couple days ago. It could have been after a Windows update or an Nvidia update, though, but I'm not entirely sure.

 

Now when I launch the game I get "LEGO Island failed to start."

 

Everything is set to WinXP SP2 compatibility and 256 colors.

Share this post


Link to post
Share on other sites
Xir

I know for a fact that on Windows 10 LEGO Island likes to boot once, and then after that you need to delete the stuff in the registry for it to boot again - at least that's how it went in my experience several months ago. As well, I currently use a GTX 960 on Windows 7 and it works fine. I betcha if I was to boot into my Win10 partition I'd have issues.

 

 

Edit: Just noticed the teleportation boundaries if you walk too far out on the water, nice! I was wondering if you could walk off the world or not. :P

Share this post


Link to post
Share on other sites
bphillips09

Do you remember what it is that needs to be removed from the registry?

 

Also, this should give you a better idea of where I have the colliders for changing the music:

 

http://i.imgur.com/iTs0TdQ.png

 

Share this post


Link to post
Share on other sites
Wognif
2 minutes ago, bphillips09 said:

Windows 10 64-bit with an Nvidia GTX 970

It worked perfectly until a couple days ago. It could have been after a Windows update or an Nvidia update, though, but I'm not entirely sure.

 

Now when I launch the game I get "LEGO Island failed to start."

 

Everything is set to WinXP SP2 compatibility and 256 colors.

Seeing how I'm not using Windows 10, I have no idea how to fix that, however, I found an interesting glitch in your remake earlier.

When walking on water, (which is my favorite thing to do even in the original, haha) in some places the original water texture vanishes, leaving behind only the animated water.

I actually kinda like it like this; the animated water really livens it up a bit.

large.islandwithrealwater.png.cbf88be0fa

Share this post


Link to post
Share on other sites
Xir

I'm not really sure, I just deleted everything relating to LEGO Island. I'm going to switch over to my W10 now to check.

Share this post


Link to post
Share on other sites
bphillips09
Just now, Wognif said:

Seeing how I'm not using Windows 10, I have no idea how to fix that, however, I found an interesting glitch in your remake earlier.

When walking on water, (which is my favorite thing to do even in the original, haha) in some places the original water texture vanishes, leaving behind only the animated water.

I actually kinda like it like this; the animated water really livens it up a bit.

 

Hidden Content

 

I'm not sure why it disappeared, but the animated water I was using has a lot of reflection and refraction settings that I haven't messed around with yet, so that could be why. I was considering removing the original water entirely, but decided just to set the texture as transparent and fade it about 50% so it's still somewhat visible. 

 

Do you think I should replace the original water entirely?

Share this post


Link to post
Share on other sites
Wognif
Just now, bphillips09 said:

Do you think I should replace the original water entirely?

Definitely. I like it better with just the animated water.

Share this post


Link to post
Share on other sites
Xir
1 hour ago, bphillips09 said:

Now when I launch the game I get "LEGO Island failed to start."

So, if I delete the options settings from the registry, and try to run Isle.exe first, I get "LEGO Island failed to start" if I run either the confige.exe or LEGOIsle.exe first, I get an infinite black screen. I'll be back later to report more.

 

Edit: The game doesn't even run on my Win10 at all, period. :/

Share this post


Link to post
Share on other sites
bphillips09

I updated the game to version v0.5. The changes and link are in the initial post.

Share this post


Link to post
Share on other sites
Xir
On 2016-03-16 at 8:27 PM, bphillips09 said:

What's new: 

  • Made walking a slight bit faster and running a little slower.
  • Added 8 audio interactions that change every time you walk into the cave. (The hints that are normally found atop the info center

 

Still to do for v0.6:

  • Fix the building mesh colliders (I'm considering just using box colliders instead)

 

Questions: 

Regarding interiors, do you guys think I should recreate them in widescreen 1080p to match the style? Or should I just use the 4:3 low-quality originals?

For controls, do you think objects should be clickable in the original game? Or should there be a crosshair marker that utilizes an action key/button?

New:

  • I like the new sprint speed, I'm not sure about the walking (unless maybe ctrl for slow speed was added)
  • I think you need to make the audio box for the playing speech a slight bit deeper in the cave (the line changes if you reach the wall and back up). ;)

 

v0.6:

  • How does the mesh colliders work exactly? I'm not too familar with Unity, but maybe I can help with that regardless.

 

Reply:

I'd say use the low resolutions I've provided for now, and consider HD later on. Maybe even going as far as recreating the rooms in 3D.

 

 


 

As you've added respawn walls around the island, could you perhaps place one on the water too (at least for the time being)

Share this post


Link to post
Share on other sites
Wognif

I downloaded the new version, but my antivirus mistook it for a trojan horse. I tried allowing it, but the installation kept having errors upon creating files.

(The "Could not create file" kind of errors.)

Share this post


Link to post
Share on other sites
bphillips09
1 minute ago, Xiron said:

New:

  • I like the new sprint speed, I'm not sure about the walking (unless maybe ctrl for slow speed was added)
  • I think you need to make the audio box for the playing speech a slight bit deeper in the cave (line changes if you reach the wall and back up). ;)

 

v0.6:

  • How does the mesh colliders work exactly? I'm not too familar with Unity, but maybe I can help with that regardless.

 

Reply:

I'd say use the low resolutions I've provided for now, and consider HD later on. Maybe even going as far as recreating the rooms in 3D.

I'll fix those first two issues. Are you saying you think walking is too slow or too fast?

 

You can read about mesh colliders in Unity here: http://docs.unity3d.com/Manual/class-MeshCollider.html

Basically, I can import an object and have Unity automatically generate a collider that forms to the object's shape/size. It works great for most objects put when you have buildings and such made from planes (like the ones from lego island), it can generate too many or two few triangles and can cause issues. 

 

I'm currently using your interiors and am creating a "2.5D" version for now that uses all 4 "sides" of an interior and switches between them depending on if you go left or right. This might turn out to be a bad way of doing it, but we'll see.

 

Here's an example from the infocenter interior. The scene view is on the left and the in-game view is on the right. You can kinda see what I'm talking about by creating somewhat of a "cube" for the interiors: 8uu6Fev.png 

3 minutes ago, Wognif said:

I downloaded the new version, but my antivirus mistook it for a trojan horse. I tried allowing it, but the installation kept having errors upon creating files.

(The "Could not create file" kind of errors.)

Woah, weird. I can guarantee you it's not a virus of any kind. The only reason I'm using an installer is so I can utilize the game's original launcher (the one with the Run/Config/Cancel buttons) since all it does is run an executable from a registry path, so the installer places the files and shortcuts and creates a registry entry for the launcher to use. Your antivirus might be detecting the installer as a virus because it makes a registry entry. 

 

Instead, you can just replace the contents of "C:\LIRedux\Data" with the files in this zip: 

https://www.dropbox.com/s/r576nfk14ew5y1f/Data.zip?dl=0

Share this post


Link to post
Share on other sites
Xir

I was implying it to be a bit to fast.

 

Aaah, okay. Auto generated. Might there be a way to manually create/import a collision model?

 

Oh, 2.5, that's a neat idea. It may not work for all places though (i.e places with 2 rooms only).

Share this post


Link to post
Share on other sites
bphillips09
1 minute ago, Xiron said:

I was implying it to be a bit to fast.

 

Aaah, okay. Auto generated. Might there be a way to manually create/import a collision model?

 

Oh, 2.5, that's a neat idea. It may not work for all places though (i.e places with 2 rooms only).

Ah ok. I only increased it by 1, but I can put it back down. Better yet, I can make it changeable whenever I get around to creating a settings menu, so you can customize the speed to whatever you like. 

 

You can create primitive colliders (like box/sphere/plane/circle colliders) or you can edit the automatically generated colliders. I'm not entirely sure if it's possible to import colliders or how that would be done.

Share this post


Link to post
Share on other sites
Xir

Eh, I'm fine with non-configurable speed so long as the one set in place is established to be reasonable. ;)

Well, at least we can confirm my unsurity between if the walk speed was slow or run to fast now. :P

Share this post


Link to post
Share on other sites
Wognif
32 minutes ago, bphillips09 said:

Woah, weird. I can guarantee you it's not a virus of any kind. The only reason I'm using an installer is so I can utilize the game's original launcher (the one with the Run/Config/Cancel buttons) since all it does is run an executable from a registry path, so the installer places the files and shortcuts and creates a registry entry for the launcher to use. Your antivirus might be detecting the installer as a virus because it makes a registry entry. 

 

Instead, you can just replace the contents of "C:\LIRedux\Data" with the files in this zip: 

https://www.dropbox.com/s/r576nfk14ew5y1f/Data.zip?dl=0

Phew. Thanks, that fixed it. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now