Welcome Guest!

Did you know you that by registering, you can gain access to new special powers? You’ll be able to reply to Topics, create your own Topics, talk in our Chatbox, message members, manage your profile, access extra content and much more! Best of all, this message & ads will vanish!

JHUYSER

lego island not working on windows 10 64 bit

6 posts in this topic

I am trying to run lego island on windows 10 64 bit and it will not work on compatibility mode

Share this post


Link to post
Share on other sites

Inb4 JHUYSER says "but that says it is for Windows 7 and Vista" and didn't even attempt it on Windows 10 in case it might work there too. :P

Share this post


Link to post
Share on other sites

Playing it on Windows 10 right now.... Here, this is what I did.

 

First download le717's alternate installer, linked here: https://github.com/le717/Island-Alternate-Installer/releases

You can use the one that comes on the CD but it is not recommended at all because it can cause frequent crashes.

Now insert the CD into your computer.

Install the game with the alternate installer.

After that go to the game icon and right click on it.

Click on open file location.

Find the files: LEGOISLE, ISLE (application not the icon), and CONFIG.

Right click on them one at a time and click properties.

Set it to run as administrator and check the compatibility mode and run it under Windows XP Service Pack 3.

After doing that to all three files, open up the CONFIG file.

Click Advanced

Set Direct 3D Devices to RAMP Emulation

Check mark the boxes: Draw 3D to Video Memory, and Flip Video Memory Pages.

Doing this prevents crashes.

Now open the game and have fun!

Share this post


Link to post
Share on other sites

If I run it with compatibility mode it crashes the moment the Information Centre interior appears, but if I don't then it at least gets as far as the Infomaniac appearing and starting to speak before crashing. One random compatibility mode I tried had the same result but made faint flowers appear in the Information Centre...

 

I'm also running Windows 10 64 bit. The installer that comes from the CD works for me and I can run Config.exe without compatibility mode. I've set up RAMP Emulation, running as administrator, copied over d3drm.dll or whatever and tried all combinations of compatibility mode but nothing works. Is there any hope?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now