Welcome Guest!

Did you know you that by registering, you can gain access to new special powers? You’ll be able to reply to Topics, create your own Topics, talk in our Chatbox, message members, manage your profile, access extra content and much more! Best of all, this message & ads will vanish!

Cyrem

LEGO Racers 1 EXE Parameters

94 posts in this topic

The 'LEGORacers.exe' can be run with a few different parameters, here they are:

[table]

ParameterParameter Affect

-novideo Disables Video Playback at the game start

-window Run in Windowed Mode (16bit)

-primary Force use of primary display device

-select3d Allows 3D device selection

-alphatrans Force use of alpha transparency

-horzres [res] Set desired Horizontal resolution

-vertres [res] Set desired Vertical resolution

[/table]

Share this post


Link to post
Share on other sites

So, what do I do with these? Add them to the shortcut?

EDIT: I can't get this to work. Just where do I add them?

Share this post


Link to post
Share on other sites

So, what do I do with these? Add them to the shortcut?

Add them to the end of the shortcut after the closing quote, yes.

Share this post


Link to post
Share on other sites

Huh, it's giving an error saying it's not valid...

Share this post


Link to post
Share on other sites

Huh, it's giving an error saying it's not valid...

Tell me the Target link you are using.

Share this post


Link to post
Share on other sites

The -window one doesn't work.

Share this post


Link to post
Share on other sites

The -window one doesn't work.

Are you using it correctly? These would have extracted directly out of Racers.exe (or whatever it's called), so I'm sure they are all working perfectly.

Share this post


Link to post
Share on other sites

"correctly"? How hard is it to simply add -window just like any other command?

Share this post


Link to post
Share on other sites

"correctly"? How hard is it to simply add -window just like any other command?

Just making sure. The last person I helped didn't know how to make a forum post...his name was "ericmg123", and he made 2 one words posts, one of which got locked. Ain't seen his face ever again...

Share this post


Link to post
Share on other sites

I can't get the -window param to work either, with or without the -horzres [res] and -vertres [res].

Share this post


Link to post
Share on other sites

I can't get the -window param to work either, with or without the -horzres [res] and -vertres [res].

Windowed mode works for me once I change from 32 bit graphics to 16 bit via the control panel (I have to do the same thing to get Rock Raiders to run in windowed mode). I also got the resolution things to work a while back, but I can't remember what I had to do.

Share this post


Link to post
Share on other sites

I also got the resolution things to work a while back, but I can't remember what I had to do.

You have to put the number of where the res is (I don't know why Cyrem put [res] when it was just simply res in the .exe)

Share this post


Link to post
Share on other sites

I also got the resolution things to work a while back, but I can't remember what I had to do.

You have to put the number of where the res is (I don't know why Cyrem put [res] when it was just simply res in the .exe)

Because, he's indicating you write an integer value in there...res is a variable/placeholder.

Share this post


Link to post
Share on other sites

You know guys, it says 16Bit right there in the table, did any of you even notice?

Share this post


Link to post
Share on other sites

You know guys, it says 16Bit right there in the table, did any of you even notice?

We aren't talking about that particular command?

Share this post


Link to post
Share on other sites

Do you guys know how to make the game use your hardware graphics card option? I tried the -select3d command

but it is locked on the primary device driver. :rf: When i try to change the resolution of the game to something over 640 by 480

it crashes and says that the video device is out of memory. :'( That's why i am trying to change lego racers driver settings.

Anyone that could shed me some light on the subject would be most helpful. Thanks! :B

Share this post


Link to post
Share on other sites

@Modded Lego: Please login or register to see this link. , and what you're describing is exactly what the topic post says.

As for the out of video memory, I only get that when I bump up the resolution when it's on my Please login or register to see this link. . Are you by any chance on a netbook so something like that? Those Atom CPUs and what-they-call-a-GPU will give you that message for sure.

1 person likes this

Share this post


Link to post
Share on other sites

Oh ok so the program is hardware mode by default? WELL...THAT'S DUMB! xD

Ok well at least it's in hardware acceleration mode, thanks for the reply. :lol:

and about the netbook, no i am running it from my C drive inside the computer. I am using the -horzres (put res here) and -vertres (put res here) commands from the shortcut to make the graphics better. I would like to have the graphics at least to 1440 by 990 resolution.

Share this post


Link to post
Share on other sites

The only reason the game is already in hardware mode is because it's 2012. In 1999, there were graphics cards that did not fully support LR. Using the -select3d command was to force the game to use hardware mode. But since it's 2012, all graphics cards fully support LR, so the switch is has changed roles, namely, to force the game to use software mode.

Share this post


Link to post
Share on other sites

but that still dosen't explain why my computer crashes when i try to change the resolution.

Share this post


Link to post
Share on other sites

Some games don't support weird resolutions, like the one you're listing. Try 1024x768 first. If it doesn't work, it's possible that you're not entering the codes correctly. To make sure you are, try entering 800x600.

Share this post


Link to post
Share on other sites

you mean enter it like this: horzres (800x600) or like this: -horzres 800 -vertres 600?

Share this post


Link to post
Share on other sites

Second

you mean enter it like this: horzres (800x600) or like this: -horzres 800 -vertres 600?

Second one. "-horzres 800 -vertres 600"

Share this post


Link to post
Share on other sites

The game changes resolutions fine for me.

Just to let you know, the game was not optimized to run in higher resolutions. If you go anything above 640 x 480, the menus get nudged into the corner and a lot of text becomes unreadably small.

Share this post


Link to post
Share on other sites

@legoking831 The game wasn't optimized to run at high-res, but it can. The races work perfectly actually (http://youtu.be/mzo08fFm28I), but it's the menus as you said that have problems. But that can be fixed by editing a .MIB file (which as of last update, origamiguy had only one sucessful loading file). http://dl.dropbox.com/u/3770169/screens/2011_09_08_17_21_35.png <origamiguy's pic

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now