Solved Custom Biomes not Working.


18 posts in this topic

Posted · Report post

I fixed it with the help of all these geniuses here! I mean that seriously! Thank you sooooo much!

The results

gallery_53_290_190669.png

The problem

I posted for help in the World Textures - Wishlist topic, but Cirevam suggested I post my own. So now I am.

gallery_53_290_39765.png

This is now my problem. I've gotten the crashing sorted. But as I said in the a fore mentioned topic:

All I get is a gray, untextured world!

What am I doing wrong?

Share this post


Link to post
Share on other sites

Posted · Report post

When we shall help you, you have to give information (so also post it here!).

Please post the names of the texture bmp-files, the folder name they are in and the LEGO.cfg part where it says:

 

Textures {

 

...

 

YourTexture {

rooftexture WorldWorldTexturesYourTextureRoof.bmp
surftextwidth 8
surftextheight 8
meshbasename WorldProMeshesYourTexturePM
texturebasename WorldWorldTexturesYourTextureFolderYourTexture
}
 
...
 
}
 
 
 
By the way, this is still the wrong forum section, you should have gone to Mod Discussion, because it is a modification, no general discussion!

Share this post


Link to post
Share on other sites

Posted · Report post

You said you renamed all the textures "DESXX". That's a BIG no-no. They MUST be named exactly as the other biomes have them named, otherwise the game won't recognise them.

 

Bite me.

Share this post


Link to post
Share on other sites

Posted · Report post

They MUST be named exactly as the other biomes have them named, otherwise the game won't recognise them.

I have never heard of this rule before, and I'm pretty sure I've renamed the texture files before. 

Share this post


Link to post
Share on other sites

Posted · Report post

They MUST be named exactly as the other biomes have them named, otherwise the game won't recognise them.

I have never heard of this rule before, and I'm pretty sure I've renamed the texture files before.

Then how does LegoRR know which one is each specific texture? It's not listed anywhere in the .cfg...

Share this post


Link to post
Share on other sites

Posted · Report post

Then how does LegoRR know which one is each specific texture? It's not listed anywhere in the .cfg...

If it weren't listed in the CFG how would it even find the texture files? /:|

texturebasename WorldWorldTexturesYourTextureFolderYourTexture

Or are you saying something else? 

Share this post


Link to post
Share on other sites

Posted · Report post

Then how does LegoRR know which one is each specific texture? It's not listed anywhere in the .cfg...

If it weren't listed in the CFG how would it even find the texture files? /:|

texturebasename WorldWorldTexturesYourTextureFolderYourTexture

 

That points to the folder where the textures are located. The folder can be renamed whatever, but the actual textures inside the folder must be numbered exactly like those ones.

 

And on research, he's named them correctly ("apparently", I'd like to take a look at his folder setup). **** me.

 

RRF#1, I want you to zip up your textures and have a .txt file with your .cfg entries, and the filepaths to where you had the textures located. Make sure you include the roof texture you're using, because that's in a separate file.

Share this post


Link to post
Share on other sites

Posted · Report post

That points to the folder where the textures are located. The folder can be renamed whatever, but the actual textures inside the folder must be numbered exactly like those ones.

It says folder right above that in the directory. The files can be named whatever. They have to be numbered the same, yes, but I assumed you were saying that they could only be called Rock, Ice or Lava.

Share this post


Link to post
Share on other sites

Posted · Report post

That points to the folder where the textures are located. The folder can be renamed whatever, but the actual textures inside the folder must be numbered exactly like those ones.

It says folder right above that in the directory. The files can be named whatever. They have to be numbered the same, yes, but I assumed you were saying that they could only be called Rock, Ice or Lava.

I forgot about the word before the numbers ;P

Share this post


Link to post
Share on other sites

Posted · Report post

Here it is!

 

It's the code snippet, the roof and the textures, all set for evaluation.

Share this post


Link to post
Share on other sites

Posted · Report post

Looking through it now, get back to you eventually.

BTW, your link is missing a colon ( : ) after the http which makes it redirect and break. Please add it.

Share this post


Link to post
Share on other sites

Posted · Report post

Fixed

Share this post


Link to post
Share on other sites

Posted · Report post

The mistake - in my view - is very obvious. 

 

This is the code in the CFG:

 Desert {
    rooftexture       WorldWorldTexturesrockroof.bmp
    surftextwidth     8
    surftextheight     8
    meshbasename      WorldProMeshesRockPM
    texturebasename     WorldWorldTexturesDesertSplitDesert
 

 

 
FIRST:
The '}'at the end is missing
 
SECOND:
You wrote 'rockroof.bmp' to the rooftexture, but your actually rooftexture is DESERTROOF.bmp (but that doesn't make the textures crash).
 
THIRD:
You wrote 'WorldWorldTexturesDesertSplitDesert' to the texturebasename, but the texturebasename of your textures is 'DES' and not 'Desert'!
 
It is actually explained exactly enough so this mistake shouldn't have happened... why didn't you follow the instructions?
2 people like this

Share this post


Link to post
Share on other sites

Posted · Report post

And a quick other note, rooftexture       WorldWorldTexturesrockroof.bmp

You should make sure all your textures are in caps. Right now about half are DESXX and the other half are desXX. Pick one or the other and make sure you write it in caps in the .cfg.

EDIT: Alan. Y u do dis 2 meh? I think I might be blind.

Share this post


Link to post
Share on other sites

Posted · Report post

FIRST: The '}'at the end is missing

 

 

It is there, I just forgot to include it.

 

 

It is actually explained exactly enough so this mistake shouldn't have happened... why didn't you follow the instructions?

 

 

I didn't think they were clear. But, now I know. So next time I want to add another biome texture, I'll refer back to this

 

Thank you all for the help you've given me.

Share this post


Link to post
Share on other sites

Posted · Report post

You should make sure all your textures are in caps. Right now about half are DESXX and the other half are desXX. Pick one or the other and make sure you write it in caps in the .cfg.

Not necessarily. The game doesn't mind whether the BMPs are in caps or not (just tested it and some of the original textures are not in caps too (for me)).

 

 

 

@Rock Raider fan no.1:

You can change the topic to solved now ;)

Share this post


Link to post
Share on other sites

Posted · Report post

You should make sure all your textures are in caps. Right now about half are DESXX and the other half are desXX. Pick one or the other and make sure you write it in caps in the .cfg.

Not necessarily. The game doesn't mind whether the BMPs are in caps or not (just tested it and some of the original textures are not in caps too (for me)).

Consistency is important in any project.

Share this post


Link to post
Share on other sites

Posted · Report post

Yes, but in this case it's not so important because it also works with caps and non-caps at the same time used.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now